Roll 173. Ruined Kentmere 400

I took the Rollei 35 LED and some film on vacation to Stockholm. The first roll was Kentmere 400, and it did not come out well in development at all. There was horrible streaking on every frame.

Facing traffic. Kentmere 400 in Rodinal 1+50 for 20min at 20C.

Facing traffic. Kentmere 400 in Rodinal 1+50 for 20min at 20C.

These two frames where the ones where the streaking was the least visible, but if you look closely you can still see vertical dark bands.

Looking back. Kentmere 400 in Rodinal 1+50 for 20min at 20C.

Looking back. Kentmere 400 in Rodinal 1+50 for 20min at 20C.

Too much agitation? Too little agitation? I don’t know, but I haven’t been very pleased with any of the Kentmere film I have developed since I started with film photography.

Advertisements
This entry was posted by Wilhelm.

2 thoughts on “Roll 173. Ruined Kentmere 400

    • I doubt it, I think we went by train for that trip.

      I think it may have been a result of insufficient agitation during the fixing phase. I have started agitating more in the fix, and have not seen such problems since.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: